miércoles, 16 de septiembre de 2009

Otro pto. de vista, otra faceta.

Está nota, a primera vista, no tiene nada que ver al mundo de la informática, pero algo de su reflexión circula en un mundo concreto que se presenta, quizás en algún sentido, propio de la mala difusión que hay de las "cosas". Ôô.

"Este standar de pensamiento, que la gente comenta lo que pasa en los medios y no tiene impresiones de 'reflexión' ?"


lunes, 7 de septiembre de 2009

Instalar Skype Debian - Ubuntu

Para las personas que deseen instalar Skype en Debian - Ubuntu, deben seguir los siguientes pasos:

sudo gedit /etc/apt/sources.list

Agregamos la siguiente linea:

deb http://download.skype.com/linux/repos/debian/ stable non-free

Ahora lo típico despues de agregar un repositorio:

sudo apt-get update
sudo apt-get install skype

Y ya tenemos nuestro skype instalado.



Fuente: http://ulibertad.wordpress.com/2007/09/11/instalar-skype-en-debian-de-32-bits/

Saludos,

Emmanuel Arreguez

domingo, 26 de julio de 2009

Videos sobre Python.


Buscando en google sobre python me encuentro con una pag. enlace
en la cual encuentro una lista con vídeos sobre el lenguaje que va desde lo más básico (variables, listas, sintaxis), hasta orientado a objetos y un poco más.
Les dejo la dirección de la lista, espero que les sirva a los que se inician en este lenguaje tan entretenido.
Los vídeos están en ingles, pero como dice en la pag. son fácil de entender.
LISTA DE VIDEOS

lunes, 6 de julio de 2009

Fallo de Segmentación

Si estas intentando instalar algún paquete desde la consola mediante las herramientas:
  • apt-get
  • aptitude
y de repente sale un aviso de fallo de segmentación.

Ejemplo:
root@ponchito:~$ aptitude install python-simpy
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... 50%
Fallo de segmentación
Lo que tenemos que hacer es borrar unos archivos (.bin) que se encuentran en el directorio /var/cache/apt/.
Como usuario root escribimos el siguiente comando en la consola.
rm /var/cache/apt/*.bin
Y ahora volvemos a probar con la instalación de algún paquete con las herramientas mencionadas y tendría que funcionar normalmente.

martes, 9 de junio de 2009

Como saber la cantidad de Memoria que Disponemos en nuestro Sistema Freebsd

Hola a todos,

Como algunos saben la manera de ver la memoria que tenemos disponible en un sistema "Linux" es usando la aplicacion (free), ejemplo:

Se podria usar free solamente para bytes o free -m en caso que se quiera saber en Mb.



Pero aqui la cuestion si estamos en sistemas con Freebsd.
Seguramente habrá mas de 2 opciones para ver la memoria disponible, yo solo voy a mencionar 2 formas:

Primera: Usando el comando (cat /var/run/dmesg.boot | grep memory)

Segunda: Instalando desde los ports de freebsd la aplicacion muse

Aqui la direccion del ports: "/usr/ports/sysutils/muse"

Una vez instalada la aplicacion se puede utilizar muse para bytes o muse -m para Mb.

Aqui el pantallazo:




Saludos,

Emmanuel Arreguez

jueves, 28 de mayo de 2009

Chat - IRC

Hola.

Bueno los q solemos conectar a chats de irc seguramente conoceremos mirc, ircap.

En linux existen varias alternativas pero mi preferida es xchat.

Para instalar en Debian/Ubuntu:

sudo apt-get install xchat

Si en un caso no queremos instalar nada y acceder via web lo podemos hacer desde la siguiente pagina:

http://embed.mibbit.com/?server=SERVIDOR&channel=%23CANAL&noServerTab=false&autoConnect=true

Deberiamos modificar (servidor) y (canal) por los que preferamos.

Ejemplo:

http://embed.mibbit.com/?server=irc.irclatino.net&channel=%23catamarca&noServerTab=false&autoConnect=true

Fuente: http://www.linux-noa.com.ar/2009/04/chat-irc-en-ubuntu.html

Saludos,

Emmanuel Arreguez

domingo, 17 de mayo de 2009

Instalar Impresora Epson Stylus S20,T10,T11,T20,T23,T26, en Debian Lenny / Ubuntu

Hola a todos,

Hoy voy a postear como instalar la impresora (en mi caso) epson t23 en debian lenny y ubuntu.

El primer paso es descargar el archivo desde la web:

http://www.ircdshells.com.ar/linux/epson-pips.tar.gz

Entramos al directorio donde sea que sea que hayamos descargado el archivo, en mi caso:

# cd /home/emmanuel/Desktop

Descomprimimos el archivo:

# tar zxvf epson-pips.tar.gz

# cd epson-pips

Instalamos los drivers:

# sudo dpkg -i *.deb

Copiamos el archivo "ekpd":

# sudo cp ekpd /etc/init.d/ekpd

Damos Permiso de Ejecucion:

# sudo chmod +x /etc/init.d/ekpd

Agregamos ekpd para que se ejecute al inicio:

# sudo update-rc.d ekpd defaults

Instalamos 2 librerias:

# sudo apt-get install libtiff4 libpng3

Creamos el siguiente enlace simbolico:

# sudo ln -s /usr/lib/libtiff.so.4.2.1 /usr/lib/libtiff.so.3

Copiamos el archivo de configuracion:

# sudo cp /usr/local/EPAva/printer/st20/ekpdrc_st20 /etc/ekpdrc

Ejecutamos la aplicacion "ekpd-tool":

# sudo ekpd-tool

En mi caso los valores que puse son los siguientes:



Ahora iniciamos el demonio ekpd:

# sudo /etc/init.d/ekpd start

Ahora abrimos el configurador de impresoras:

# gksu system-config-printer

O en su defecto vamos al menu "Sistema/Administracion/Imprimiendo"

Hacemos clic en "Nuevo" y nos aparece una ventana como esta, damos clic en "Adelante"

Y nos encontramos con lo siguiente, elegimos "Epson" y clic en "Adelante"

Elegimos "Stylus T23" y clic en "Adelante"


Aqui le ponemos un nombre a la impresora (no debe tener espacios)


Y por ultimo clic en "Aplicar"

Y listo ya con esto tenemos la impresora Epson Stylus T23 funcionando

Saludos,

Emmanuel Arreguez

domingo, 10 de mayo de 2009

Combinación de teclas en Linux.

Altgr + Q = @
Altgr + Shift + Z = <
Altgr + Shift + X = >

Estas son algunas de las combinaciones útiles que podemos utilizar a falta de un teclado que viene si la tecla <>.

Quizás estos caracteres varíen según la configuración de tu teclado.

domingo, 3 de mayo de 2009

Error de Libreria instalando Eggdrop en Servidor Centos 5

Hola,

Si por esas cosas de la vida tratando de instalar un eggdrop en un servidor centos, cuando le damos ./configure:

# ./configure

Empieza a cargar todo bien y en un momento determinado salta el siguiente error:

configure: error:

Tcl cannot be found on this system.

Eggdrop requires Tcl to compile. If you already have Tcl installed on
this system, and I just wasn't looking in the right place for it, re-run
./configure using the --with-tcllib='/path/to/libtcl.so' and
--with-tclinc='/path/to/tcl.h' options.

See doc/COMPILE-GUIDE's 'Tcl Detection and Installation' section for more
information.
Es que nos falta una libreria llamada (tcl-devel)

Verificamos si es que esta instalada con:

# rpm -qa|grep tcl

Nos sale lo siguiente:

root@tango [~]# rpm -qa|grep tcl
tclx-8.4.0-5.fc6
tcl-8.4.13-3.fc6

Para instalar esa libreria ponemos:

# yum -y install tcl-devel

Al toque se nos instala, chequeamos si es asi:

root@tango [~]# rpm -qa|grep tcl
tclx-8.4.0-5.fc6
tcl-8.4.13-3.fc6
tcl-devel-8.4.13-3.fc6

Ahora si estamos en condiciones de compilar nuevamente el eggdrop.

# ./configure

Y ya no nos dara errores.

Saludos,

Emmanuel Arreguez

Cambiar idioma ingles/español de OpenOffice y Firefox

Hola,

Por lo general cuando hacemos una instalacion de debian/ubuntu (sin conexion a red) el openoffice y firefox se instalan en ingles.
Para pasarlos a castellano simplemente vamos a escribir en consola:


# sudo apt-get install openoffice.org-l10n-es openoffice.org-help-es


# sudo apt-get install mozilla-firefox-locale-es-es



# sudo apt-get install thunderbird-locale-es-es

Saludos,

Emmanuel Arreguez

Servidor LAMP en Debian 4.0 etch

1.- configuramos la lista de fuentes para descargar efectivamente los paquetes desde los repositorios:


Nos logueamos como root con (su) y le damos matraca


# nano /etc/apt/sourcers.list

y agregamos la siguiente linea:

deb http://ftp2.fr.debian.org/debian etch main contrib non-free

guardamos y salimos

2.- acualizamos la lista de repositorios con el siguiente comando:

# aptitude update

3.- Ahora instalamos los programas correspondientes:

Apache y Php5

# apt-get install apache2 php5 libapache2-mod-php5

los siguientes comandos nos permitiran iniciar, detener y reiniciar el servidor apache

# /etc/init.d/apache2 start
# /etc/init.d/apache2 stop
# /etc/init.d/apache2 restart

para comprobar si esta funcionando apache, es solo cosa de ir a la siguiente direccion: http://localhost

MYSQL

# apt-get install mysql-server mysql-client php5-mysql

Se nos creará una cuenta root sin contraseña, por lo que deberemos asignarle una de la siguiente manera:

# mysql -u root
mysql> use mysql
mysql> UPDATE user SET Password=PASSWORD(’pon-tu-contraseña’) WHERE user=’root’;
mysql> FLUSH PRIVILEGES;
mysql> exit

NOTA: Donde dice pon-tu-contraseña, es obvio que debes reemplazarla por una contraseña que desees

PHPMYADMIN

# apt-get install phpmyadmin

Eso es todo.

Saludos,

Emmanuel Arreguez

miércoles, 29 de abril de 2009

Abstracciones lógicas.

Fases del aprendizaje. (Pasaje racional)
  1. Percepción de la situación del problema.
  2. Análisis.
  3. Descubrimiento de solución.
  4. ¿!Integrar conocimiento¡?, (las exclamaciones no son la solución.)
  5. Fijación.
  6. Transferir.

Pero factores esencial están faltando en la lista. (Pasaje emocional)
  • Interés.
  • Motivación.
  • Otros ... =)
... Esto aplicado a todo y no solo a la superación de uno mismo. ;)

Plugin CurrentSond Amarok emesene

Quizas no es de mucha importancia, pero otra pequeña solución no hace mal a nadie.
Resulta que tengo instalado emesene en Ubuntu con entorno Gnome y de este software,(emsene), quería correr el plugin CurrentSong para mostrar lo que estas escuchando con Amarok (KDE).
Lo que necesitamos instalar para que funcione este plugin precisamente para la aplicacion Amarok es instalar lo siguiente.

sudo apt-get install python-dcop


link para entender de que se trata el Dcop. Esta información es importante si sos programador y necesitas utilizar comunicación entre procesos.

viernes, 20 de marzo de 2009

Problema instalando flashplugin-nonfree en Ubuntu 8.04

Hola a todos, este post va dedicado no para los debianeros sino para los ubunteros 8.04
Seguramente intentando instalar los plugins de flash para tu firefox pusiste un simple:

# sudo apt-get install ubuntu-restricted-extras

Y por sorpresa cuando este conjunto de paquetes intenta instalar el paqu flashplugin-nonfreee te ves que te salen unos mensajes como estos:

Se instalarán los siguientes paquetes NUEVOS:
flashplugin-nonfree
0 actualizados, 1 se instalarán, 0 para eliminar y 4 no actualizados.
Necesito descargar 18,7kB de archivos.
Se utilizarán 168kB de espacio de disco adicional después de desempaquetar.
Des:1 http://archive.ubuntu.com hardy/multiverse flashplugin-nonfree 9.0.124.0ubuntu2 [18,7kB]
Descargados 18,7kB en 1s (11,2kB/s)
Preconfigurando paquetes ...
Seleccionando el paquete flashplugin-nonfree previamente no seleccionado.
(Leyendo la base de datos ...
142255 ficheros y directorios instalados actualmente.)
Desempaquetando flashplugin-nonfree (de .../flashplugin-nonfree_9.0.124.0ubuntu2_i386.deb) ...
Configurando flashplugin-nonfree (9.0.124.0ubuntu2) ...
Downloading...
--04:38:56-- http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
=> `./install_flash_player_9_linux.tar.gz'
Resolviendo fpdownload.macromedia.com... 72.247.130.70
Conectando a fpdownload.macromedia.com|72.247.130.70|:80... conectado.
Petición HTTP enviada, esperando respuesta... 404
Not Found
04:38:57 ERROR 404: Not Found.

download failed
The Flash plugin is NOT installed.

Como se queda colgado en la descarga del archivo install_flash_player_9_linux.tar.gz ya que no encuentra su ruta, lo que vamos a hacer es descargar manualmente ese archivo y darle otra ves el install para que cuando se ejecute el script primero chequee si existe ese archivo, como va a existir ya que lo vamos a descargar manualmente va a saltear la parte de la descarga que es donde se traba.

Creamos la carpeta en caso que no exista:

# mkdir /var/cache/flashplugin-nonfree

Vamos a:

# cd /var/cache/flashplugin-nonfree

Descargamos el archivo:

# wget http://www.ircdshells.com.ar/linux/install_flash_player_9_linux.tar.gz

Ahora volvemos a instalarlo:

# sudo apt-get install flashplugin-nonfree

Y ya nos va a decir que se instalo bien:

(Leyendo la base de datos ...
141923 ficheros y directorios instalados actualmente.)
Desempaquetando flashplugin-nonfree (de .../flashplugin-nonfree_9.0.124.0ubuntu2_i386.deb) ...
Configurando flashplugin-nonfree (9.0.124.0ubuntu2) ...
Installing from local file /var/cache/flashplugin-nonfree/install_flash_player_9_linux.tar.gz
Flash Plugin installed.

Ahora si ya podemos disfrutar el plugin de flash

Saludos!!

Emmanuel Arreguez